Jump to content

Stormtrooper Hearing Assist not working anymore


Recommended Posts

Hello everyone!
Before talking about the problem, I would like to give some context first.

I bought the Stormtrooper Hearing Assist via a friend from my Garrison(Peru). He went on a trip to the U.S and brought it here.

I checked Ukwrath's website for guidance, search some posts and yt videos to be ready. And also bought the correct 9v battery for it to work.

When I installed the battery, everything worked fine so I started doing the work on my helmet: drill some holes, attached some things... But I still got plenty of cables (also from my helmet's fans) out so I decided to use a grey tube to hide everything. 

(In this process I was constantly moving the SHA's cables. I dont know if maybe this has something to do with it not working anymore.)

I proceeded to test if the grey tube fitted and it did, also test SHA's system and it worked too.
So I cleaned up the surface for the grey tube (it got some dry e6000 dirt) with some Isopropyl alcohol (just in case) and then install it for good.

https://imgur.com/a/3j43HVE

But now the SHA didn't work, I dont get the red light to bright up. I don't know if it's the battery but it wouldn't make much sense because it is only one week old.

As stated before, im not sure if, while moving the cables so much, something came loose.
Some has experience with this?

Last, would be great if I could fix it somehow by myself. Shipping the device back to the U.S would be expensive.

Pd: I will also reach Ukwrath's for help

Thanks
Greetings from Peru

 

Link to comment
8 minutes ago, IcyTrooper said:

Hello, friend! I'm tagging @ukswrath here as well.

Are there any parts of the cords at 90 degree angles? If something was pinched it could have broke a connection.

David PMed me. We're working on it. Thanks Ryan

  • Like 1
  • Thanks 1
Link to comment
  • 2 weeks later...

Hey @IcyTrooper!! I moved the cables but not that extreme, I also thought that it could be bad for the connections if I put it on 90 degree. At the end I made a "U" shape with the cables, still something could have been pinched as you say. Here is a link for a video that helps explain the situation (I also sent it to @ukswrath a couple of days ago).

I guess Ill need to find an electrician that can help me repair this since I don't have the required tools.

https://drive.google.com/drive/folders/1ayA1Llval1hHwwsi-V43cV48ixYUOehn?usp=sharing

  • Thanks 1
Link to comment

Is it worth trying another 9v battery or at least wiping down the connections for the 9v battery & it's connection? This would be the cheapest fix if it works.

If not, then it's either the cable from the battery to the unit or the unit itself that is the issue.

I'd always try the easiest & cheapest fix 1st.

  • Like 1
Link to comment
  • 2 weeks later...
  • 4 weeks later...
  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.